[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: please take a look at an ocaml-related apt bug (171542)

On Sun, Feb 23, 2003 at 02:23:39AM +0000, Faheem Mitha wrote:
> Dear People,
> On Dec 3rd 2002 I filed a bug (Debian bug 171542) for a build
> dependency problem involving advi and ocaml against apt. I'm not sure
> whether this really is an apt bug or an ocaml bug. I was wondering if
> someone could take a look at this and perhaps shed some light on it. I
> don't know what is going on here, but clearly something a little
> peculiar. Thanks.
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=171542

Err, i did look at the bug report, but it was not clear what version you
where trying to build. You say the latest version from unstable, but it
is not clear if it is the new 1.4.0-3, or an older version like one of
the post 1.2.0-date cvs snapshots.

Anyway, notice that the new version build depends on the exact same
version of ocaml that you are using, and so it is not (easily) possible
to build ocaml 1.4.0-3 with the 3.04-12 version of ocaml in testing, you
would have to modify the debian/control file for it, because we don't
depend on ocaml anymore, but on ocaml-3.06 (for ocaml versions prior to
3.06-13), or ocaml-3.06-1 (for ocaml versions since 3.06-13), which both
provide ocamltk.

The best solution to this is to use Stefano's woody backport of the
ocaml 3.06 packages, or simply wait the two weeks needed for ocaml
3.06-15 to enter testing, if no new glibc bug appears in the meantime.


Sven Luther

Reply to: