Re: [RFH] Compiling a Gnome app / GTHREAD or XDamage error
Laszlo Boszormenyi wrote:
> On Thu, 2006-03-23 at 18:20 +0100, Bastian Venthur wrote:
>> checking for GTHREAD... configure: error: Byzanz requires GThread-2.0 >=
>> and XDamage >= 1.0 to compile.
>> make: *** [config.status] Error 1
>> Currently my package build-depends on: debhelper (>= 4.0.0),
>> autotools-dev, libexpat1-dev, libxdamage-dev, libpanelappletmm-2.6-dev,
>> intltool, libgtk2.0-dev
>> Any idea?
> There's a wonderful simple search place: http://packages.debian.org/
> At the bottom, choose unstable and search for libgthread as keyword.
> It reveals that libglib2.0-dev contains: /usr/lib/libgthread-2.0.so
The problem sits deeper! I've included this package before and received
the same error. I even took the ubuntu package and tried do build it in
a clean pbuilder environment and guess what? It fails exactly with the
So something really strange is going here. Maybe a bug in one package in
> Just a question: is it so poorly known that anyone can search for
> package contents?
Nope, I know packages.d.o but I still was not *sure* which package was
PS: Please don't CC me, I read the list.