[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Pre-RFS: axkit (orphaned), latex-xft-fonts



Matt Kern (matt.kern@undue.org) wrote:
> I have had a look at the axkit package.  On the whole it looks good,
> but I haven't had a chance to really put it through its paces yet.
> One comment though; when I run lintian over the changes it throws up a
> number of warnings:
> 
> W: axkit source: newer-standards-version 3.6.0
> N:
> N:   The source package refers to a `Standards-Version' which is newer than
> N:   the highest one lintian is programmed to check. If the source package
> N:   is correct, then please upgrade lintian to the newest version. (If
> N:   there is no newer lintian version, then please bug
> N:   lintian-maint@debian.org to make one.)
> N:
> W: axkit-examples: extra-license-file usr/share/doc/axkit-examples/examples/axkit.org/license.xml
> N:
> N:   All license information should be collected in the debian/copyright
> N:   file. This usually makes it unnecessary for the package to install
> N:   this information in other places as well.
> N:   
> N:   Refer to Policy Manual, section 13.5 for details.
> N:
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/AxKit.pm
> N:
> N:   Architecture-independent Perl code should be placed in
> N:   /usr/share/perl5, not /usr/lib/perl5.
> N:
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Language.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/LibXMLSupport.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Exception.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/CharsetConv.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Cache.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/ConfigReader.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Provider.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/StyleChooser/FileSuffix.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/StyleChooser/Cookie.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/StyleChooser/QueryString.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/StyleChooser/UserAgent.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/StyleChooser/PathInfo.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Language/LibXSLT.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Language/XPathScript.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Language/SAXMachines.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Language/XSP.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Language/Sablot.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Language/XSP/SimpleTaglib.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Language/XSP/TaglibHelper.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Plugin/QueryStringCache.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Plugin/Fragment.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Plugin/Passthru.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/MediaChooser/WAPCheck.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Provider/FileWrite.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Provider/File.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Provider/Scalar.pm
> W: axkit: package-installs-nonbinary-perl-in-usr-lib-perl5 usr/lib/perl5/Apache/AxKit/Provider/Filter.pm

The warning about the Perl modules in the 'wrong" location has never been officially
approved by the project.  This warning has been added by the lintian maintainer due
to someone filing a bug report but without consensus on the debian-perl mailing list.
As fas as I'm concerned (I'm the previous maintainer of the axkit packages) there's
no need to spend the effort in "fixing" these warnings.  That time can be spend much
more useful to our users by e.g. packaging all the other AxKit modules.

Thanks,
Ardo
-- 
Ardo van Rangelrooij
home email: ardo@debian.org
home page:  http://people.debian.org/~ardo
GnuPG fp:   3B 1F 21 72 00 5C 3A 73  7F 72 DF D9 90 78 47 F9



Reply to: