[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#189164: libdbd-mysql-perl uses GPL lib, may be used by GPL-incompatible apps

Le Tue, Apr 15, 2003 at 02:29:52PM -0500, Steve Langasek écrivait:
> The latest version of libdbd-mysql-perl build-depends on
> libmysqclient-dev.  I'm afraid that, although this fixed the FTBFS bug,
> it potentially renders some software in our archive non-distributable.
> Because the new libmysqlclient12 package is licensed under the GPL, any
> GPL-incompatible apps which depend on libdbd-mysql-perl would be in
> violation of the libmysqlclient12 license.

I disagree completely with this bug.

The perl module "links" to libmysqlclient12, but the perl module is
available under the GPL so it's ok.

Any other program/script "uses" DBD::mysql but doesn't link to
libmysqlclient12 ... so there's no problem on that side either.

> I have not had a chance to look through the list of packages that depend
> on libdbd-mysql-perl to see if any of these are actually
> GPL-incompatible; however, libmysqlclient10 has been reintroduced to the
> archive for just this sort of situation.  Please consider changing your
> build-dep back to libmysqclient10-dev and dropping the libssl-dev
> build-dep.

Not until you can convince me that my interpretation of the license is
clearly wrong. 

I'm ccing debian-legal to have further input.

Raphaël Hertzog -+- http://www.ouaza.com
Formation Linux et logiciel libre : http://www.logidee.com

Reply to: