[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

broken cd-rw drive

Hi group,

I broke my cd-rw drive. I really hope this has nothing to do with a
possible bug in linux and/or cdrecord. Here's my story...

I have an ASUS L5800C.

I use kernel 2.4.26 and after some upgrade in debian sid I lost
automatic loading of the ide-scsi module. But, since cdrecord can
address atapi drives now, that was not really a problem. After some
time, I noticed that I couldn't burn cds in dao mode. I could only burn
them in tao mode. I was going to sort that out some other time. That
time came when I wanted to burn a video cd and k3b could only do that in
dao mode. I tried, but the burning process hangs at 'burned 1 Mb / many
Mbs' messages. It starts the burning process, but hangs at the first Mb.
After a minute or so, the burning process is aborted with a strange
error (unknown to k3b) which I don't recall literally and (obviously, as
we will see) can't reproduce now. I fidgeted around with unloading the
ide-cd/cdrom modules and loading the ide-scsi module. It started
burning. It hanged at 1 Mb again, but after a minute it continued with
the rest. Since it was only a test, I aborted the burning process with
Ctrl-C (it was a cdrecord burn, not k3b). So far, so good. Later, having
finished my video cd images, I tried again with k3b and it hanged at 1
Mb. I tried erasing the cdrw again, but cdrecord told me there was no
medium inserted. I tried reloading the ide-scsi modules, then the
ide-cd/cdrom modules, but to no avail. I tried another cdrw disk,
nothing. I tried mounting a cdrom, nothing. I tried playing an audio cd,
nothing. I tried in windows, nothing. I even tried (nice feature on my
laptop) to power off the machine, touch that nice little audio cd
button, inserting an audio cd and pressing the play button. This way, I
can normally play audio cds while my laptop remains powered down. But
now, not even this hardware application is able to determine the fact
that there _is_ a cd inserted. The drive is dead.

The reason I think it _might_ be linux related is the fact that it died
when I was trying to let it burn in dao mode: reloading different
modules and such. Could this be? When I have replaced the drive, I
certainly don't want to experience this again. What is the status of
atapi support in cdrecord and cdrdao and 2.4.26: should it be able to
write in dao mode to all drives? If so, maybe my drive was faulty for
some time, now...


Hi! I'm a .signature virus. Copy me into
your ~/.signature to help me spread!

Reply to: