[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [debian-knoppix] Multiple hardware issues



Am Montag, 28. April 2003 03:30 schrieb Michael Grenier:
> OK, I gave up getting the onboard sound working when booting from the
> CDROM.

hm, thats the best solution: Anyway: 
http://www.alsa-project.org/alsa-doc/doc-php/template.php3?company=VIA&card=&chip=via8233a&module=via82xx

... which makes me wonder

>
> I disabled it in the BIOS and plugged in a Crystal chipset audio card.
> This now
> works fine with Knoppix CD.
>
> I did an modprobe cs46xx
> which finally got it working on the hard disk boot.
>
> How does one run the hardware probing scripts from Knoppix to
> automatically create
> the /etc/modules file with the correct stuff when changing hardware?

That is not yet possible, but you can add it to /etc/modules yourself.

cu

Fabian
>
>    -Mike
>
> Michael Grenier wrote:
> > Alsa did not help - I still got the errors below from the latest
> > 4/18/03 distribution.
> >
> > However, alsa did add the following lines to the errors:
> > ---
> > preparing modules for alsa
> > Building card database
> > Configuring via82xx
> > Running update-modules
> > Setting default volumes
> > insmod: Note: /etc/modules.conf is more recent than
> > /lib/modules/extra/modules.dep
> > -----

The last is no error.
> >
> > Interesting that it is configuring for the sound card but it still
> > doesn't work.  xmms just hangs up.

Huh ? hangs up. Interesting.

> >
> > At the bottom of this, I've attached a dmesg output from a CD boot and
> > the second one is
> > from a hard disk boot using the OSS drivers. Note that it does load
> > the solo1 driver.

alsa does not write kernel messages unless build with debug-flags.
_______________________________________________
debian-knoppix mailing list
debian-knoppix@linuxtag.org
http://mailman.linuxtag.org/mailman/listinfo/debian-knoppix


Reply to: