[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Loading firmware: untranslated dialog (bug #575456)

On Fri, 2010-03-26 at 07:21 +0100, Christian PERRIER wrote:
> (see #575456)
> Frans closed the bug report (which is the right action) with the
> following comment:
> > This dialog does not come from D-I, but from linux-2.6. I suspect that that 
> > was not 100% translated for the version currently in testing.
> > 
> > Closing this report.
> However, this could mean it would be a good idea to add "linux-2.6" to
> the list of packages in either level 2 or 3 as it is likely to show
> some internationalized material during some installs.
> CC'ing the Kernel Team (I hope I'm using the right mail address): if
> we go this way, where should I "pick" for kernel packages debconf
> translations (which VCS).

I agree we should have translations for at least the common debconf
questions and notes.

The VCS branch for uploads to unstable is

Templates for linux-base are in debian/linux-base.templates.

Templates for linux-image-* are in
debian/templates/temp.image.plain/templates, but these are actually
templates for templates as we need to substitute in the kernel version
and so on.  We'll apply those substitution to the translations too.

The substitutions currently used are:
=ST : package name prefix, i.e. 'linux'
=V  : current ABI version (upstream version + ABI number), e.g. 2.6.32-4


Ben Hutchings
Once a job is fouled up, anything done to improve it makes it worse.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: