[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#509923: marked as done (linux-2.6: hd's no longer found on marvell 88SE6145 sata controller)

Your message dated Mon, 1 Feb 2010 14:14:10 +0100
with message-id <20100201131410.GC9849@stro.at>
and subject line Re: Bug#509923: linux-2.6: hd's no longer found on marvell 88SE6145 sata controller
has caused the Debian Bug report #509923,
regarding linux-2.6: hd's no longer found on marvell 88SE6145 sata controller
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

509923: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=509923
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: linux-2.6
Version: 2.6.26-12
Severity: important

As the title says, kernel 2.6.26-12 introduced the problem, 
that my discs on the marvell sata controller are no longer found.
I have already found bug nr. 507432, but opened a new bug, since I
suspect, that the patch that fixed the before mentioned bug is the source
of my problem. I have also tried kernels 2.6.27-10 and 2.6.28 from 
kernel.org and they show the same problem. This is lspci output from 
the controller, the board is an intel badaxe2.

03:00.0 SATA controller: Marvell Technology Group Ltd. 88SE6145 SATA II PCI-E controller (rev a1) (prog-if 8f)
        Subsystem: Intel Corporation Device 5842
        Flags: bus master, fast devsel, latency 0, IRQ 16
        I/O ports at 3018 [size=8]
        I/O ports at 3024 [size=4]
        I/O ports at 3010 [size=8]
        I/O ports at 3020 [size=4]
        I/O ports at 3000 [size=16]
        Memory at 9d100000 (32-bit, non-prefetchable) [size=1K]
        Expansion ROM at 98300000 [disabled] [size=256K]
        Capabilities: <access denied>
        Kernel driver in use: pata_marvell
        Kernel modules: ahci, pata_marvell

-- System Information:
Debian Release: 5.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.28-a1 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

--- End Message ---
--- Begin Message ---
On Mon, 26 Oct 2009, Tom Jägermeister wrote:

> Hi Ben,
> this issue was almost a year ago but I can remember it as it was quiet 
> annoying.
> It turned out that I had to use module 'ahci' instead of 'pata_marvell', I 
> found the hint in the kernel config. However in the previous kernels (before 
> 2.6.26-12 pata_marvell had worked alright).
> Unfortunately pata_marvell seems to be preferred over ahci for the mentioned 
> controller, so I had blacklisted the module and built all later kernels 
> without it. No more problems after ...

closing as this indicates only a stable device names bug,
which is userspace related and should be fixed by newer d-i that uses
UUID and maybe soon on upgrade too.

--- End Message ---

Reply to: