[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#439242: ipw3945-modules-2.6.21-2-686: Older prebuilt package takes precedence over newer package built with m-a

Package: ipw3945-modules-2.6.21-2-686
Version: 1.2.2-1+2.6.21-6
Severity: normal

The versioning info of the prebuilt packages seems to be different from
the versioning used by module-assistant, so that after auto-install'ing
the ipw3945-1.2.2-1 kernel module, aptitude wants to "upgrade" it to
Debian's own ipw3945-1.2.1-3:

   ~-0# aptitude upgrade                                     
   W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
   Reading package lists... Done
   Building dependency tree       
   Reading state information... Done
   Reading extended state information       
   Initializing package states... Done
   Reading task descriptions... Done  
   Building tag database... Done    
   The following packages have been kept back:
     libgmp3-dev libgmp3c2 tzdata 
   The following packages will be upgraded:
     ipw3945-modules-2.6.21-2-686 ipw3945-modules-2.6.22-1-686 
   2 packages upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
   Need to get 0B/595kB of archives. After unpacking 81.9kB will be freed.
   Do you want to continue? [Y/n/?] 
   (Reading database ... 190131 files and directories currently installed.)
   Preparing to replace ipw3945-modules-2.6.21-2-686 1.2.2-1+2.6.21-6 (using .../ipw3945-modules-2.6.21-2-686_2.6.21+1.2.1-3_i386.deb) ...

Maybe this is not specific to ipw3945 but to module-assistant, tho: I don't use it nearly often enough to be able to tell.


-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.21-2-686 (SMP w/2 CPU cores)
Locale: LANG=fr_CH.UTF-8, LC_CTYPE=fr_CH.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages ipw3945-modules-2.6.21-2-686 depends on:
hi  linux-image-2.6.21-2-686 [lin 2.6.21-6   Linux 2.6.21 image on PPro/Celeron

ipw3945-modules-2.6.21-2-686 recommends no packages.

-- no debconf information

Reply to: