[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#438337: linux-source-2.6.18.dfsg.1-12etch2: Megaraid Legacy driver stopped working with IntelSRCU42x.

Package: linux-source-2.6.18.dfsg.1-12etch2
Version: linux-source-2.6.18
Severity: normal

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-tcc
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

After upgrading from sarge kernel-source-2.6.8 package to etch
linux-source-2.6.18, the Megaraid Legacy driver (known as megaraid in
kernel 2.6.8) stopped working. The RAID controller in use by the machine
is an Intel SRCU42x.

During the first machine boot with the new kernel, we got a kernel panic
stating the impossibility to mount the root partition.

The driver version included in the 2.6.8 linux kernel sources is the
2.00.3, while the version included in the 2.6.18 linux kernel sources is
the 2.00.4.

Reply to: