[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#369784: ide-disk module not insmod'ed

Package: linux-image-2.6.15-1-686
Version: 2.6.15-8

Recently I upgraded four of my machines to etch; three of them are ok,
but one doesn't boot with new kernel 2.6.15.
Boot process stops at "waiting for root filesystem", long pause and
"no /dev/hda1" message; after this, I receive a busybox shell.

in busybox, one can see /dev handled by udev and, really, no /dev/hd* at
all. insmod /lib/modules/.../ide-disk.ko fixes the situation: /dev/hd*
appearing and one can press ctrl-D to continue booting.

rebuilding initrd with ide-disk added to /etc/mkinitramfs/modules also
fixes the situation; booting wents ok (except long pause while "waiting
for root filesystem").

This problem exists with 2.6.15 only (both image from etch and
backports.org image for sarge), bot not with any other kernel (2.6.8-*
from sarge, 2.6.16 from backports.org)

Here follows lspci:
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host
bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP
bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:0f.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro
100] (rev 10)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC
AGP (rev 7a)

Reply to: