[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Squeeze KDE unusable: no taskbar or decorations, missing shortcut key

I had the same problem on my testing/unstable installation and I solved 
it when I realised that kdelibs5 had not been updated (in my case it was held
back by kdelibs5-dbg, so upgrading these two simultaneously from unstable,
solved my problem).

So, if you installed kde 4.4.4 from unstable  make sure you got the whole

In my case the error became obvious when I tried to run systemsettings
and got this output:

systemsettings(24094) SettingsBase::initApplication: "View load error: The 
plugin 'classic_mode' uses an incompatible KDE library (4.4.4 (KDE 4.4.4))." 

Hope this helps.

John Varouhakis.-

Στις Δευτέρα 14 Ιουνίου 2010 02:31:45 Martin Ågren γράψατε:
> Hi!
> After a recent upgrade of squeeze -- but I have also been removing
> some packages since my last working reboot -- I no longer have a
> usable installation of kde. I get a very basic plasma desktop with the
> calculator and dictionary (as configured by me) apart from the
> "Desktop Folder". No window decorations on the "Desktop Folder", no
> taskbar, no anything. Just a white background and these three windows.
> Some applications, notably Amarok and the network manager, seem to
> start but they do not show anywhere (as the taskbar is indeed gone).
> Going Alt+F2 -> "System Activity" and right-clicking e.g., amarok and
> selecting "Show Application Window" doesn't do anything. (I admit I
> don't know if it's supposed to. :) )
> By pressing Meta+O, I can trigger Amarok's On-Screen Display, but
> similarly, Meta+K does not start an instance of Konsole, as I have it
> configured to.
> I have moved my ~/.kde/ aside and logged in, but it basically just
> leads to the same non-usable situation (of course, with default
> appearances, e.g., no calculator+dictionary configuration). I have
> tried installing kde-full, thinking that there might be some missing
> dependency, but that didn't improve anything as far as I could see.
> plasma-desktop is running and killing it makes everything pure
> black...
> I would really appreciate any pointers as to what could be the
> problem. I don't really know which information to provide in order to
> bring more light on this, and would be glad to provide anything deemed
> interesting.
> Take care,
> Martin

Reply to: