[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot login


Some weeks ago I had exactly the same behaviour as you in my debian testing system.
I cannot login to kde  "with kdm". When I tried to login to kde I get kdm's login screen again.
Also, and I think that that is the problem we have, I applied https://developer.skype.com/jira/browse/SCL-510.
Until now, I thought that the fix to skype was not what caused the problem with the login, but now, I think that that's the problem, because I have exactly the same problem with the login as yours and the problem start exactly after I applied the fix to skype's (Until now, I thought that the problem comes with a patch upgrade or something like that).

I made the following tests:
- Create a new user and tried to login and get the same behaviour.
- Check free space and all was ok.
- Rename <userhome>/.kde to <userhome>/.kde_old and <userhome>/.kde4 to <userhome>/.kde4_old and I get the same behaviour.
- I tried to undo the recommendations in https://developer.skype.com/jira/browse/SCL-510 with no success (but I really don't know if I do all the steps to restore the system as before the fix)
- I remove the kdm and reinstall it with no success
- I remove all kde packages and reinstalled, also with no success :-(
- I could start kde with no problem from a console, stopping the kdm and executing startx with my user. Can you try this?

Finally I applied the following workaround: I remove kdm and installed gdm. After that, I have no problem to login. I haven't investigated any further because I really don't know from where the problem comes, but now, maybe we have to undo the steps applied with the skype's solution to solve our problem.

I hope this helps to solve our problem

P.D. Sorry for my typos

Un saludo,

Daniel Sutil

On Tue, Apr 6, 2010 at 8:46 PM, Smokejohn <smokejohn@gmail.com> wrote:

On Tue, Apr 6, 2010 at 9:23 PM, Steven Crooks <steven@worldofcrooks.org> wrote:
On Tuesday 06 April 2010 19:31:19 Smokejohn wrote:
> On Tue, Apr 6, 2010 at 7:57 PM, Klaus Becker <colonius@free.fr> wrote:
> > Le Mardi 06 Avril 2010 18:35:51, John Kapnogiannis a écrit :
> > > Hello there. I got a debian testing installation and I currently cannot
> > > login in kde. I give my pass and instead of a proper kde session I get
> > > kdm's login screen again. I haven't done any upgrade but I did a really
> > > stupid thing: I hit the power button and turn the laptop off the hard
> > > way while it was in suspend mode. I tried googling but it gave me no
> > > usefull things.
> > >
> > > The .xsession-errors file in my home folder says Permission denied. I
> > > checked the permissions in /tmp and /var/tmp and everything seems fine.
> > > I also deleted the .kde folder. Login in as root and typing startx
> > > opens a kde session.
> > >
> > > Any ideas?
> > >
> > > PS: I did the instructions described in this page:
> > > https://developer.skype.com/jira/browse/SCL-510 in order to fix skype
> > > on me 64-bit installation, but I don't think it has something to do
> > > with my problem. I think something got wrong when I hit the power
> > > button. :(
> >
> > Hi,
> >
> > perhaps
> >
> > #chown -R john /home/john
> >
> > or any username you use ?
> >
> > If this does'nt work, you can try to create a new user and then cope all
> > your
> > files to /home/new-user.
> >
> >
> > Nope did not help. Adding a new user did not fix anything too. I tried
> login in a console and then startx and I got some errors about xkb not
> being able to get initialized. Strange....  So the thing is that no user
> except the root can start a kde session.

Just for completion:

Check if there is enough space on your/the harddisk.


There is plenty of space. I think something messed up the permissions cause the laptop was in suspend mode when I repeatedly pressed the power button. So it has to be my bad and not a bug or something.


Reply to: