[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Konqueror 3.1.2 problem with JavaScript

On Tue, Jun 24, 2003 at 06:41:23PM +0200, Frank Murphy wrote:
> > > Since I apt-getted up to 3.1.2 a week ago, Konqueror has trouble with
> > > JavaScript. Yahoo! Mail thinks I don't have JavaScript, as do
> > > allmusic.com and raiffeisen.ch.
> >
> > It works for me in Konqueror 3.1.2.  I am running Debian unstable on a
> > sparc64-based system.
> Can you tell me a site you use that uses JavaScript so I can tell if mine 
> works with that site as well?

I mean Yahoo Mail works for me with Konqueror 3.1.2.  I don't know if
'allmusic.com' works and, as before, the 'raifeisen.ch' does not work.
Further testing on the Swiss site shows that it doesn't complain if I
use Mozilla 1.3.1.

I generally have no problem with Javascript and Konqueror -- to the
point where I'm surprised when I run into a site that doesn't work.
On my Intel-based system at home, I can even use sites that play video
with Javascript and the Realplayer plug-in.

> The wierd thing for me is that this all worked with Konq 3.1.1. Is there 
> something else I could've changed to affect this?

Uh-oh - now that you mention it, I find my Javascript isn't working
anymore either.  I looked in .xsession-errors and found out that the
Javascript library is having trouble:

kdecore (KLibLoader): WARNING: library=kjs_html: file=/usr/lib/kde3/kjs_html.la: libpcreposix.so.3: cannot open shared object file: No such file or directory

A recent system update I made must have screwed it up.  I made a
temporary fix by symbolically linking libpcre.so.3 to
libpcreposix.so.3.  Now Javascript works again and I can now even get
the initial login screen on "https://tb2.raiffeisendirect.ch/";.


Roy Bixler <rcb@ucp.uchicago.edu>
The University of Chicago Press

Reply to: