[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: configure error on debian woody kde 2.2.2

On Sat 27 Jul 2002 18:17, gerhard wrote:
> Am Samstag, 27. Juli 2002 18:01 schrieb gerhard:
> > Hi all,
> >
> > I'm a debian 3.0 woody user and cannot install kpovmodeler.
> > I receive the following error from the configure-script:
> >
> > checking for KDE... configure: error:
> > in the prefix, you've chosen, are no KDE headers installed. This
> > will fail.
> > [...]
> Sorry:
> After apt-get install  kde-devel ./configure can find the
> kde-headers now, but not the OpenGL headers, although libqt2
> libqt-dev are the newest packets of my installation.
> error:
> checking for the Qt OpenGL extension... no
> configure: error: your system is not able to compile
> an application that uses the Qt OpenGL extension!
> Make sure the OpenGL headers are installed and Qt is compiled with
> OpenGL
> support to compile kpovmodeler.
> See the file REQUIREMENTS for further information.
> debian:/home/gerhard/download/kpovmodeler/kpovmodeler-0.1.1#
> apt-get -t unstable -u install  libqt2 libqt-dev
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Sorry, libqt2 is already the newest version.
> Sorry, libqt-dev is already the newest version.
> debian:/home/gerhard/download/kpovmodeler/kpovmodeler-0.1.1#
> apt-cache search OpenGL glut glu glx
> libopengl-perl - Perl module to display 3D data using OpenGL, GLU,
> GLUT, and GLX
> debian:/home/gerhard/download/kpovmodeler/kpovmodeler-0.1.1#
> apt-get install libopengl-perl
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Sorry, libopengl-perl is already the newest version.
> How can I resolve the requirements of kpovmodeler? What are the
> libs and dev packets of OpenGL I'll need to compile it properly?
I can't speak for KPovModeler, but OpenGL is provided by Mesa on Linux. 
OpenGL is NOT free, but Mesa is supported by OpenGL and provides the same 
API's and development stuff. Have a look for Mesa and install that. After 
that, any other requirements for KPovModeler have to be found from the 
KPovModeler sources, and I don't understand C++ enough to begin to tell you 
where to look. The ./configure errors should give you clues as to what else 
is missing though.

> Requirements for KPovModeler
> ----------------------------
> The program requires:
> - KDE-2.1.x with header files
> - Qt-2.3.x with header files
> - OpenGL, glut, glu, glx libraries and header files
> - The Qt OpenGL extension.
> I don't know the needed packets of OpenGL/qt, and apt-cache shows a
> bunch of hits, but which one fit's?
> Any clues?
> gerhard

To UNSUBSCRIBE, email to debian-kde-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: