[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#127252: -unstable compiled against the wrong libpng

* Colin Watson <cjwatson@debian.org> [020101 15:44]:
> > > binary packages built from kdeutils depend on libpng directly. Why?
> > 
> > I can only guess, but I heard that are systems where an shared library
> > can not depent on other shared libraries so the application has to
> > link against all. Perhaps they want KDE to run on such systems, too?
> That would be a fair point, but I understand all Debian systems support
> inter-library dependencies.

If some kde-app is using libpng directly then an "enhanced" script may
brake these, if qt does no longer link against libpng, as any upstream
source would most likely not link directly against it as the normal
script does it.
But I'm again guessing and do not know if there is a real chance for
this or if the maintainer did simply not realize it. And perhaps there
is some other reason for directly linking...

  Bernhard R. Link

Reply to: