[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#127252: -unstable compiled against the wrong libpng

On Tue, 1 Jan 2002 21:25:24 +1100
Mark Purcell <msp@debian.org> wrote:

> The incompatibility as I see it from here is that any application
> which depends on libpng2, is only good with libpng2 <= 1.0.12-2 and
> upon recompiling will be dependant on libpng3.
> libqt 2.3.1-18 has been recompiled and now depends on libpng3, but almost every
> other package needs to be recompiled as well :-(

I suggest re-introducing libpng2, and libpng-dev.
And also libpng3, and libpng3-dev.
This will be clear that anything that wants to enter 
"testing" should use libpng2.

libpng is used by many libraries, and also end applications,
which is causing the problem.
How did people solve the libdb issues? (or is it really solved?)


Reply to: