[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: new eclipse 2.1 deb


  great job. I am very glad to have my favourite ide available in

  I've got a problem with the current version of eclipse though and am
not sure if that is related to the packaging and if I should open a bug

  I upgraded to the new version and after trying to compile a plugin I
got the following message: Error during build:
java.lang.NoClassDefFoundError encountered while running
org.eclipse.pde.internal.builders.ManifestConsistencyChecker. (copied by
hand) ...

  I also downloaded 2.1/gtk2 as zip file and tried to create a new
plugin project with all the defaults (so almost empty). It worked, but
repeating that steps with the packaged version gave me the same error
message as mentioned above.

  Any idea?


On Sun, 2003-04-06 at 16:46, Takashi Okamoto wrote: 
> Hi, 
> I uploaded new eclipse 2.1 deb in my apt-line
> deb http://people.debian.org/~tora/deb ./
> I would like to hear your comment before upload sid. I thank for all
> people who give comments. Especially Jan Schulz, he send worth
> comments (though I don't reflect all his comments yet).
> Here is changelog:
> eclipse (2.1-2) unstable; urgency=low
>   * fixed following bugs reported by Jan Schulz:
>      - ant-optional is linked two times (at least two times the same
>        entry in eclipse-platform.links)
>      - org.eclipse.jdt-feature is in platform and jdt included.
>      - error in eclipse.jdt.links: the second link must probably be to
>        apache and not apahce.
>   * add debug function for script. (thanks Jan Schulz)
>   * eclipse args is enable. See eclipse man page.
>   * create separated packages eclispe-pde and eclipse-source.
>   * enable emacs key binding for code assist.
> Takashi Okamoto

Reply to: