Re: unmet dependencies
Riccardo Mottola, on Mon 16 Jan 2017 10:07:20 +0100, wrote:
> You might want to run 'apt-get -f install' to correct these.
> The following packages have unmet dependencies:
> gnupg : Breaks: dirmngr (< 2.1.17-2) but 2.1.16-2 is installed
> Recommends: dirmngr (= 2.1.17-2) but 2.1.16-2 is installed
> Recommends: gnupg-l10n (= 2.1.17-2) but it is not installed
> hurd : Depends: hurd-libs0.3 (= 1:0.8.git20161120-1+b2) but
> 1:0.9.git20161219-1 is installed
> Recommends: bf-utf-source but it is not installed
> E: Unmet dependencies. Try using -f.
> should I downgrade something? how?
> Or perhaps removing gnupg temporarily?
> Wht version of hurd-libs do you have, Richard?
All of the above is outdated. Basically.
I'd say just follow the advice given by the tool: 'apt-get -f install'