Re: unmet dependencies
On Mon, Jan 09, 2017 at 02:31:34PM +0100, Riccardo Mottola wrote:
> I run apt-get update and then upgrade tells me:
> You might want to run 'apt-get -f install' to correct these.
> The following packages have unmet dependencies:
> gnupg : Breaks: dirmngr (< 2.1.17-2) but 2.1.16-2 is installed
> Recommends: dirmngr (= 2.1.17-2) but 2.1.16-2 is installed
> Recommends: gnupg-l10n (= 2.1.17-2) but it is not installed
> hurd : Depends: hurd-libs0.3 (= 1:0.8.git20161120-1+b2) but
> 1:0.9.git20161219-1 is installed
> Recommends: bf-utf-source but it is not installed
> E: Unmet dependencies. Try using -f.
> what should I do_ apparently hurds wants an aolder version of hurd-libs, but
> the last time I upgraded, the system was consistent.
What does apt-get dist-upgrade tell you ?