[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Recent version of Iceweasel along with fixes


I've started working on porting more recent versions of Iceweasel (our
binary packages are from version 17), and fixing some important issues
at the same time.

The current status is that packages are available for version 27.0-2,
and all major bugs have been fixed. I have reliably used it for several
days straight, without terminating the test processes, with many tabs,
with custom GTK themes, IPv4/IPv6 sites, SSL/TLS, and even SWF applets
through Gnash. I consider that reliable enough for practical use,
although the lack of acceleration and sound will make watching videos
a bit frustrating at times ;-).

The thread-safety issues that would lead to random crashes have been
fixed in libc0.3 2.18-1. The SSL/TLS issue is addressed in a patch
attached to bug #739658 [1]. The Iceweasel FTBFS issues themselves are
still being worked on until I'm satisfied with the result. The patch
fixing them can be found in the source packages on my personal
repository, along with the binary packages for Iceweasel and nspr :

deb http://ftp.sceen.net/debian-hurd-i386 experimental/
deb-src http://ftp.sceen.net/debian-hurd-i386 experimental/

I intend to regularly update these packages to track the experimental
branch until the changes are merged in the official repository.


Richard Braun

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?msg=5;filename=0001-Define-_PR_HAVE_SOCKADDR_LEN-for-the-Hurd.patch;att=1;bug=739658

Reply to: