[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libstdc++6 and apt

> - New installs won't have the issue.
> - If you simply run apt-get dist-upgrade (after next mirror push, i.e.
>   at most 6 hours from now), there should be no issue, both will get
>   upgraded at the same time.
> - If you install a package which pulls the new libstdc++6 without
>   pulling apt, then apt will start crashing. Fetch the rebuilt version
>   from mirrors, e.g.
>   ftp://ftp.debian.org/debian/pool/main/a/apt/apt_0.8.11.5+b1_hurd-i386.deb
>   (or any later version). and install it by hand with dpkg

I forgot to mention:

So the advice is: after next mirror push (should happen no later than 6
hours from now), run

apt-get update
apt-get install libstdc++6 apt

to install both the update libstdc++6 and apt at the same time, and
you'll be done.


Reply to: