[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#285123: marked as done (crosshurd: Dependency error with coreutils when installing)

Your message dated Sun, 22 Nov 2009 00:23:45 +0100
with message-id <20091121232345.GX4629@const.famille.thibault.fr>
and subject line #285123 most probably fixed
has caused the Debian Bug report #285123,
regarding crosshurd: Dependency error with coreutils when installing
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

285123: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=285123
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: crosshurd
Version: 1.7.5
Severity: important

When running crosshurd, this error message comes up:

The following packages have unmet dependencies:
  debianutils: PreDepends: coreutils (>= 4.5.8-1) but 4.5.3-1 is to be
  E: Broken packages
The reason for the problem is that I had this line:
 APT::Default-Release "unstable";

in my /etc/apt/apt/conf file.
The correct version of coreutils is in the "unreleased" repository, but the "unstable" repository has an older version. Workaround: drop the /etc/apt/apt.conf file while running crosshurd.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.7-mppe
Locale: LANG=en_GB, LC_CTYPE=en_GB (charmap=ISO-8859-1)

Versions of packages crosshurd depends on:
ii  dialog                    1.0-20041118-1 Displays user-friendly dialog boxe
ii  dpkg-dev                  1.10.25        Package building tools for Debian

-- no debconf information

--- End Message ---
--- Begin Message ---
Coreutils is up to date nowadays and not provided by debian-ports. This
bug is most likely fixed by the time.


--- End Message ---

Reply to: