[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: aptitude?



Hello!

On Mon, 09 Oct 2006 23:53:17 +0200, Javier-Elias Vasquez-Vivas wrote:
> It's been a while since aptitude (as of now 0.2.15.9-7) shows up as
> broken since there's a missing library:
>
> libapt-pkg-libc6.3-6-3.10
[...]
> Does any one know?

The problem is that aptitude is still a (very old?) version in hurd,
as of [1], thus depends on libapt-pkg-libc6.3-6.3.10, while apt [2] is
already providing libapt-pkg-libc6.3-6.3.11:
=====
luca@gismo:~/Downloads$ dpkg --info aptitude_0.2.15.9-7_hurd-i386.deb
[...]
 Package: aptitude
 Version: 0.2.15.9-7
[...]
 Depends: hurd, libapt-pkg-libc6.3-6-3.10, libc0.3 (>= 2.3.5-1), \
  libgcc1 (>= 1:4.0.1), libncurses5 (>= 5.4-5), libsigc++-1.2-5c2, \
  libstdc++6 (>= 4.0.1)
[...]

luca@gismo:~/Downloads$ dpkg -s apt
Package: apt
[...]
Version: 0.6.46.1
[...]
Provides: libapt-pkg-libc6.3-6-3.11
[...]

luca@gismo:~/Downloads$
=====

Digging the BTS for a hurd-specific bug didn't help :-(

Thx, bye,
Gismo / Luca

Footnotes: 
[1] http://packages.debian.org/unstable/admin/aptitude
[2] http://packages.debian.org/unstable/admin/apt

Attachment: pgp0WTaK34OJz.pgp
Description: PGP signature


Reply to: