[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Aw: Upgrade woes - was Re: install/update/upgrade dance

On 5/23/13 5:19 PM, John David Anglin wrote:
On 23-May-13, at 7:09 PM, Dave Land wrote:

On 5/23/13 4:38 PM, Dave Land wrote:
On 5/23/13 3:36 PM, Helge Deller wrote:
On 05/23/2013 09:09 PM, Dave Land wrote:
Thanks for the reply Helge. I did manage to get it to find the proper
kernel and boot from it, but I can't get it past the point where it
hands over the boot console to tty0. It *seems* to be up, but I can't
log in with PUTTY on a remote machine either by SSH or telnet. I also
tried changing the IPL list to forward it to ttyS0, but nothing shows
up on Tera-term, plus according to the LED display on the front of
the HP, it seems to have crashed. My IPL list looks something like

0: 2/vmlinux-3.9
1: root=/dev/sda4 (actually correct according to how I partitioned)
2: initrd=2/initrd.img (removed according to instructions)
3: HOME=/
4: panic=-1 (tried with and without)
5: console=tty0
6: sti=10/4/2/0
7: sti_font=VGA8x6
8: TERM=linux

Maybe this may give a little insight to what is going on?

Yes, I have an idea.

I assume your machine is up an running. Just try to ping the machine.

Are you installing via serial console?
In that case change the value of "console" in IPL to
   console=ttyS0    (which is serial port #1)
and change the "TERM=linux" to "TERM=linux 1"  (a space between linux
and 1)
This adds a 9th parameter "1" which instructs the kernel to boot into
runlevel 1.
If it boots up, you should get a request to enter the root password.

Then remount the root-filesystem read-writeable, e.g. run "mount -o
remount,rw /".

Then uncomment in /etc/inittab this line:
   T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
This instructs init ro spawn a login shell on ttyS0 (=serial console).

After that reboot again normally.


LOL, the mystery gets deeper. I tried the ttyS0 serial console edit
again (it crashed the machine before), and added the extra line with '1'
in it for run level 1, and once again it crashed, even after removing
the references for the sti console. Incidentally, I'm normally booting
to a graphics console, not serial...
So I booted back up with my old kernel and went in and edited
/etc/inittab and uncommented T0:23:respawn:/sbin/getty -L ttys0 9600
vt100 and went back and tried it again, and once again it crashed when
it tried to switch to the serial terminal. So I rebooted with my old
kernel once again, and lo & behold, when I got to the login prompt, I
also had a login prompt on my serial terminal too... and both of them
work. Still doesn't do me much good with the new kernel, but I thought
it was kind of interesting that I have tty0 and ttyS0 simultaneously on
the old kernel (2.6.26-2).

I've got one more thing to try, and that is remove the graphics card and
boot it, and see if the firmware will default to the serial terminal.
Maybe then I can get it to play nice until I do the apt-get upgrade.
Theoretically, I should be able to get it to see the graphics card once
the upgrade is finished and I reboot. I'll let you know what happens.
Thanks for all your help.

*I GOT IT!!*
The graphics card was the key! The firmware was seeing the graphics
card and automatically defaulted to it, and it evidently threw a curve
to the firmware when I re-directed to the serial console instead, and
crashed the machine (HPPA is weird!) Anyway, I jerked the top off and
pulled the card cage out and pulled the graphics card, and Voila!, it
now immediately sees the serial console as the default terminal.
Logged in and fixed my /etc/apt/sources.list, grabbed the gpg keys,
and now in the process of updating/upgrading. I'll let you all know
how it goes later on. :) Thanks again.

I seem to recall that switching to a serial console can also be done by
removing the USB keyboard!

Can you see in the dmesg log what happened when it crashed?

John David Anglin    dave.anglin@bell.net

I didn't find much in dmesg log, but I did find this in the syslog:
It's truncated because of the limits of nano in the serial terminal, but it seems it's having issues with the STI graphics... I tried to boldface the text where it happened.

May 23 10:48:21 hpviz kernel: [    1.520000] SuperIO: USB regulator enabled
May 23 10:48:21 hpviz kernel: [ 1.524000] Enabling PDC chassis warnings supp$ May 23 10:48:21 hpviz kerne[ 0.01.524000] Performance monitoring counters en$ May 23 10:48:21 hpviz kernel: [ 1.536000] VFS: Disk quotas dquot_6.5 e$ May 23 10:48:21 hpviz kernel: [ 1.536000] Dquot-cache hash table entries: 51$
May 23 10:48:21 hpviz kernel: [    1.540000] fuse init (API version 7.21)
May 23 10:48:21 hpviz kernel: [    1.540000] msgmni has been set to 14065
May 23 10:48:21 hpviz kernel: [ 1.540000] Block layer SCSI generic (bsg) dri$21 kernel: [ 0.000000] Initialized PDC Console for debugg$r/sbin/cro1.540000] io scheduler noop registered May 23 10:48:21 hpviz kernel: [ 1.540000] io scheduler cfq registered (defau$ May 23 10:48:21 hpviz kernel: [ 1.544000] PDC Stable Storage facility v0.30 May 23 10:48:21 hpviz kernel: [ 1.880000] STI GSC/PCI core graphics driver V$ May 23 10:48:21 hpviz kernel: [ 1.880000] sti 0000:01:01.0: enabling SERR an$ May 23 10:48:21 hpviz kernel: [ 1.884000] STI PCI graphic ROM found at fffff$ *May 23 10:48:21 hpviz kernel: [ 1.952000] Unable to handle STI device '0000:$* May 23 10:48:21 hpviz kernel: [ 1.956000] Serial: 8250/16550 driver, 4 ports$ May 23 10:48:21 hpviz kernel: [ 1.956000] serial8250: ttyS0 at I/O 0x3f8 (ir$ May 23 10:48:21 hpviz kernel: [ 1.956000] serial8250: ttyS1 at I/O 0x2f8 (ir$
48:213 10:19:59 hpviz kernel: [    1.960000] loop: module loaded

Dave Land
Land Computer Service

Check out my site at http://www.landcomp.net

Reply to: