[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with Etch->Lenny upgrade

On Fri, Dec 26, 2008 at 12:57:00PM -0700, Kurt Fitzner wrote:
> Perhaps I should mention a problem I had upgrading Etch to Lenny.  I
> made a Debian bug report about it because it seemed like it might be a
> general Debian issue, but now I'm not so sure.
> The gist of the issue is that df stops working after coreutils is
> upgraded until the system is rebooted with a new kernel.  This causes
> any package upgrade that depends on df (such as mysql) to fail - which
> causes the whole upgrade procedure to fail.
> I managed to get it going again by replacing df with a shell script that
> just echo'ed a pretend output for df.

What was the starting kernel version? The latest stable etch kernel?

I suspect the fault for this lies in glibc trickery, though I'm not sure
off-hand. I don't recall any changes in the kernel to these syscalls in
the gap of versions between etch and lenny.

regards, Kyle

Reply to: