[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: recovering from a failed libc6 upgrade

What about netbooting a lif image from the ESIEE people?
- exit the installation
- mount your local disk
- chroot to the disk
- install/compile newer kernel
Should work ;)

----- Original Message -----
From: "Martin-Éric Racine" <q-funk@pp.fishpool.fi>
To: "Randolph Chung" <tausq@debian.org>
Cc: <debian-hppa@lists.debian.org>
Sent: Tuesday, November 26, 2002 10:24 AM
Subject: recovering from a failed libc6 upgrade

On Mon, 25 Nov 2002, Randolph Chung wrote:

> It is an unfortunate fact that failed glibc upgrades are often not easy
> to recover from, since most anything on the system depend on it. Your
> best bet probably is to try to boot a 2.4.19 kernel if you can.

How?  I cannot load one from floppy, since we don't have floppy support.

> Or, you may have some success booting into sash and running dpkg manually
> downgrade glibc.

That's not installed by default, is it?

I tried passing init=/bin/sash by adding it on the fly using IPL.  Fails.
The kernel still says it tried killing init.

Any help is appreciated.

Martin-Éric Racine
"Kas sa tahad mind? - Nej!!! Är du en idiot?!!"
Tallinn, Eesti;
Espoo, Suomi.

To UNSUBSCRIBE, email to debian-hppa-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact

Reply to: