[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrading libc6 from 2.2.5-14.3 to 2.3.1-5 fails on 712

On Tue, Nov 26, 2002 at 10:41:24AM +0200, Martin-Éric Racine wrote:
> On Tue, 26 Nov 2002, Ralf Hildebrandt wrote:
> > Inteesting question. One could install a kernel by hand (not as a
> > package). Thus a runtime test would probably be more suited.
> The problem with a runtime test i.e. in the package's pre-install script, is by
> the time you try it, the libc binaries have already been unpacked and have
> probably overwritten the older ones.

Debian preinst scripts are run before the package is unpacked.

However I looked in libc6's preinst and postinst and couldn't find this
test at all (2.3.1-5).

> 2) if there really is no other way e.g. because recent bug fixes in the pa-risc
> kernel branch were performed, then the libc6 package should at least depend on
> some specific kernel-image version (or newer), to prevent disasters.
> Besides, this is Debian; we have the kernel-package and people should use it.
> Therefore, if this new libc6 depends upon specific kernels, it should not be a
> problem to have the package actually mandate that, by having kernel-image-2.4.19
> or newer as a dependency.

There's no requirement to user a standard kernel-image package or even
kernel-package to build the kernel. However, the libc could Conflict
with kernel < 2.4.19 and that would help at least some percentage of the

Hamish Moffatt VK3SB <hamish@debian.org> <hamish@cloud.net.au>

Reply to: