[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#667687: new patch. eglibc upload urgently required!

2012/4/22 Robert Millan <rmh@debian.org>:
> I notice that my initial patch didn't handle the library dependency
> part.  I'm attaching a new patch that fixes this issue. This makes new
> packages built against the patched libc0.1-dev depend on libc0.1 >=
> 2.13-31.
> ****VERY IMPORTANT NOTICE****: if this patch is introduced in a later
> version (rather than 2.13-31), you MUST change the version in
> debian/libc0.1.symbols.common to the first version that provides
> pthread_condattr_*etclock on GNU/kFreeBSD.

Uhm, I notice you didn't include this part.  Now packages that build
with libc0.1-dev 2.13-31 won't have a versioned dependency on libc0.1
>= 2.13-31.

Are you sure this is correct?  It seems to me that this can be a big
problem if those packages migrate to testing before eglibc does.

Robert Millan

Reply to: