[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#242490: linux-kernel-headers: Protect Linux headers from unproper inclussion

Package: linux-kernel-headers
Version: 2.5.999-test7-bk-15
Severity: wishlist
Tags: patch


The attached script implements a warning in Linux headers to prevent that
userland applications include them directly.

Patching Glibc cannot be easily automated and requires a long, but boring
task. I'll send the corresponding changes for Glibc when this patch script
is confirmed.

This may cause some breakage, so not to be applied before Sarge release..

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.25-1-k7

-- no debconf information

Attachment: linux_protect.sh
Description: application/shellscript

Reply to: