[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: OSSIM 2.2.0



Thank you Bas for the detailed information.

Best,
Angelos

On Thu, Aug 24, 2017 at 8:17 PM, Sebastiaan Couwenberg <sebastic@xs4all.nl> wrote:
OSSIM has finally published a new release, but unfortunately in its
currently form it's unsuitable for inclusion in Debian.

The most problematic issue the embedded copy of libjsoncpp without an
option to build with the system provided library. [0]

The library and the apps cannot be built in the same process any more,
requiring the library to be available before the apps can be built
(required at configure). [1] I've disabled building of the apps for now,
meaning that ossim-core will no longer be provided.

Finally the changes between 1.8.20-3 and 2.2.0 imply that the license
was changed from MIT to LGPL, but this is not properly reflected in the
source. [2]

Until these issues are resolved the ossim package cannot be updated to 2.x.

The new ossim release is required for GEOS 3.6, so when osm2pgsql 4.x is
available and OSSIM 2.x still suffers from these issues I'm likely to
remove OSSIM from Debian and OTB along with it. For the sake of the
latter I'd rather not have to take this route, but I don't have a lot of
faith left in the OSSIM project.

If you care about OSSIM and/or OTB in Debian, please help resolve these
issues in OSSIM.

[0] https://github.com/ossimlabs/ossim/issues/115
[1] https://github.com/ossimlabs/ossim/issues/114
[2] https://github.com/ossimlabs/ossim/issues/113

Kind Regards,

Bas

--
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1




--
Angelos Tzotsos, PhD
OSGeo Charter Member

Reply to: