[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#566256: g++-4.4: FTBFS because of mangled std::va_list



Package: g++-4.4
Version: 4.4.2-9
Severity: important

std::va_list has been mangled in the 4.4 release, so some more packages FTBFS
now on armel e.g. with:
/build/buildd-kdenlive_0.7.6+svn4238-1-armel-CUtj7g/kdenlive-0.7.6+svn4238/src/renderer.cpp:53: undefined reference to `QString::vsprintf(char const*, std::__va_list)'

See here:
https://buildd.debian.org/fetch.cgi?pkg=kdenlive;ver=0.7.6%2Bsvn4238-1;arch=armel;stamp=1263940764

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (200, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages g++-4.4 depends on:
ii  gcc-4.4                   4.4.2-9        The GNU C compiler
ii  gcc-4.4-base              4.4.2-9        The GNU Compiler Collection (base 
ii  libc6                     2.10.2-5       Embedded GNU C Library: Shared lib
ii  libgmp3c2                 2:4.3.2+dfsg-1 Multiprecision arithmetic library
ii  libmpfr1ldbl              2.4.2-3        multiple precision floating-point 
ii  libstdc++6-4.4-dev        4.4.2-9        The GNU Standard C++ Library v3 (d

g++-4.4 recommends no packages.

Versions of packages g++-4.4 suggests:
pn  g++-4.4-multilib              <none>     (no description available)
pn  gcc-4.4-doc                   <none>     (no description available)
pn  libstdc++6-4.4-dbg            <none>     (no description available)

-- no debconf information



Reply to: