[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Garbaged X11 emacs windows



Hello,

Starting a few days ago, GNU Emacs became unusable for me on X11. 

If I perform some operation within emacs that updates the contents of the buffer, the X11 window displays something like the new contents superimposed on the old contents. 

For example, if I run "emacs -q" , it will launch and show the *GNU Emacs* buffer with the welcome text and the red and blue drawing of the gnu. If I hit "C-h i" to go to the top level of Info, the X11 window shows the standard *info* buffer mixed with of the *GNU Emacs* buffer- part of the red/blue drawing is visible, as well as some of the welcome text. 

I've put a screenshot here: http://i.imgur.com/iUuZB.png

The terminal version of emacs does not have this problem- if I run "emacs -nw", this garbaging doesn't happen.

If I switch to a different virtual desktop, then switch back to the virtual desktop containing emacs, or if I resize the X11 emacs window, the emacs X11 window becomes ungarbaged. Unfortunately, if I perform another operation within emacs, the emacs X11 window immediately becomes garbaged again.

Since I usually use the development version of emacs24 straight from bazaar, at first I assumed that it was a new emacs bug, but this also happens with the Debian emacs23 package as well, so I suspect the problem is with a Debian X11-related package. OTOH, I haven't noticed any program besides emacs exhibiting this behavior, so I'm unsure which package to report the bug against.

I'm primarily running testing/wheezy, but I occasionally install packages from unstable.

Any advice for debugging or bug reporting is very welcome!

~Phillip

Reply to: