[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#824802: debian-edu-config: fails to upgrade from 'jessie' - trying to overwrite /etc/default/ldap2zone



Package: debian-edu-config
Version: 1.901
Severity: serious
User: debian-qa@lists.debian.org
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'jessie'.
It installed fine in 'jessie', then the upgrade to 'sid' fails
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at
https://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

>From the attached log (scroll to the bottom...):

  Selecting previously unselected package debian-edu-config.
  Preparing to unpack .../debian-edu-config_1.901_all.deb ...
  Unpacking debian-edu-config (1.901) ...
  dpkg: error processing archive /var/cache/apt/archives/debian-edu-config_1.901_all.deb (--unpack):
   trying to overwrite '/etc/default/ldap2zone', which is also in package ldap2zone 0.2-5


cheers,

Andreas

Attachment: ldap2zone=0.2-5_debian-edu-config=1.901.log.gz
Description: application/gzip


Reply to: