[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

make gosa packages php7 compliant



While testing gosa in a php7 only environment I found out that these 
changes were needed to get the GOsa² gui working for stretch:

--------------------------------------------------------------------

diff --git a/debian/control b/debian/control
index 37ac4ab..649b6c4 100644
--- a/debian/control
+++ b/debian/control
@@ -20,21 +20,22 @@ Depends:
  exim4 | mail-transport-agent,
  fonts-liberation,
  gettext,
- libapache2-mod-php5 | php5-cgi | php5-fpm,
  libcrypt-smbhash-perl,
  libjs-scriptaculous,
- php5,
- php5-cli,
- php5-curl,
- php5-gd,
- php5-imagick | imagemagick (>= 5.4.4.5-1) | graphicsmagick-im-compat,
- php5-imap,
- php5-ldap,
- php5-mcrypt,
- php5-mysqlnd | php5-mysql,
- php5-recode,
+ php,
+ php-xml,
+ php-cli,
+ php-curl,
+ php-gd,
+ php-imagick | imagemagick | graphicsmagick-im-compat,
+ php-imap,
+ php-ldap,
+ php-mbstring,
+ php-mcrypt,
+ php-mysqlnd | php-mysql,
+ php-recode,
  smarty-gettext,
- smarty3 (>= 3.1.10-1),
+ smarty3,
  ${misc:Depends},
 Suggests:
  cyrus21-imapd (>= 2.1.11),
@@ -42,7 +43,7 @@ Suggests:
  gosa-si-server,
  php-apc,
  php-fpdf,
- php5-suhosin,
+ php-suhosin,
  postfix-ldap,
  slapd,
 Conflicts:
@@ -62,7 +63,7 @@ Depends:
  gosa (= ${binary:Version}),
  latex2html,
  lyx,
- php5-cli,
+ php-cli,
  ${misc:Depends},
 Description: GOsa² development utilities
  This package contains a couple of tools to generate online
@@ -75,7 +76,7 @@ Package: gosa-desktop
 Architecture: all
 Depends:
  debconf,
- iceweasel | firefox,
+ firefox-esr | iceweasel,
  ${misc:Depends},
 Description: Desktop integration for GOsa²
  This package includes a Gosa² menu definition for your desktop
diff --git a/debian/gosa-apache.conf b/debian/gosa-apache.conf
index 21c9ab7..049a594 100644
--- a/debian/gosa-apache.conf
+++ b/debian/gosa-apache.conf
@@ -1,7 +1,7 @@
 # Include GOsa to your web service
 Alias /gosa /usr/share/gosa/html
 
-<IfModule mod_php5.c>
+<IfModule mod_php7.c>
 <Location /gosa>
     php_admin_flag engine on
     php_admin_flag register_globals off

------------------------------------------

Please note that php-xml and php-mbstring are now needed as additional 
dependencies. A lot of deprecated stuff should be fixed, too, to be on 
the safe side for future PHP releases.

Please test.

Wolfgang

Attachment: signature.asc
Description: Digital signature


Reply to: