[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#794189: use configVersion="Managed-by-Debian-Edu" in Debian Edu's gosa.conf



Package: debian-edu-config
Severity: important
Version: 1.818

With upload of gosa 2.7.4-reloaded2-1+deb8u1 a change of the gosa.conf template in the gosa package has been made (gosa-core/contrib/gosa.conf, /usr/share/doc/gosa/gosa.conf).

This update changes the md5sum of the gosa.conf template which triggers a warning dialog message on GOsa login, asking the admin to re-run the GOsa setup to work-in those changes into /etc/gosa/gosa.conf.

This message is misleading on Debian Edu and Debian LAN.

With gosa 2.7.4-reloaded2-3 (and hopefully 2.7.4-reloaded2-1+deb8u2) I introduce the possibility of using a

<conf configVersion="Managed-by-Debian.*"> XML tag in gosa.conf. The ".*" should be replaced by "-Edu" for Debian Edu and by "-LAN" for Debian LAN. If changing Debian Edu/LAN's gosa.conf, then debian-edu-config / debian-lan package should hard-depend on gosa (>= 2.7.4-reloaded2-1+deb8u2~).



However, fixing this has to wait until the release team has accepted gosa 2.7.4-reloaded2-1+deb8u2 in jessie-pu.

If the release team will not accept that change, we need to update debian-edu-config's and debian-lan's gosa.conf with the new configVersion md5sum:

<conf configVersion="3dcfa28818766382948647a15bcbcbbc">

Mike
--

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

Attachment: pgpQrC3w8TJd3.pgp
Description: Digitale PGP-Signatur


Reply to: