Pre-Depends: dpkg (>= 18.104.22.168) for dpkg-maintscript-helper okay?
According to dpkg-maintscript-helper(1), “using it unconditionally
requires a pre-dependency to ensure that the required version of dpkg has
been unpacked before. The required version depends on the command used,
for rm_conffile and mv_conffile it is 22.214.171.124:
Pre-Depends: dpkg (>= 126.96.36.199)”
However, according to Debian Policy §3.5, “You should not specify a
Pre-Depends entry for a package before this has been discussed on the
debian-devel mailing list and a consensus about doing that has been
I see 4 packages currently in squeeze that declare ‘Pre-Depends: dpkg (>=
188.8.131.52)’ (cron e16-data ntp ntpdate) and 9 in sid (apticron ccal cron
lilo midori mozplugger ntp ntpdate usb-modeswitch), but I can’t find any
discussion about this on debian-devel.
So, is it the consensus of debian-devel that adding a versioned
Pre-Depends on dpkg as documented in dpkg-maintscript-helper(1) is okay?
The present context is that I’d like this Pre-Depends also added to git,
which in the next upload will be using dpkg-maintscript-helper
rm_conffile, but the maintainers are reluctant unless Debian Policy is