[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Dependency issues



Hello, all,
	I was trying to build a program from source that said it needed
a certain perl module:
checking for XML::Parser... configure: error: XML::Parser perl module is
	required for intltool
So, I tried, and got, the following:
root@3[gnome-session-2.12.0]# apt-get install perl-modules
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  perl-modules: Depends: perl (>= 5.8.7-1) but it is not going to be
  installed
E: Broken packages
root@3[gnome-session-2.12.0]# apt-get install perl
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  perl: Depends: perl-base (= 5.8.7-3) but 5.8.7-5 is to be installed
E: Broken packages
root@3[gnome-session-2.12.0]#

	What am I doing wrong?  How can I fix this?

Thanks,
Terrence



Reply to: