[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libc6-dev dependancy problem


Can someone give me a hint as to how to solve the
following problem I got when I tried to update my sid
system yesterday?

First, here is my uname -a output.
Linux damon-3000 2.6.8 #3 Thu Aug 26 11:56:57 PDT 2004
x86_64 GNU/Linux
Here is the error I got while attempting to 'install'
after 'update' in dselect.
dpkg: dependency problems prevent configuration of
 libc6-dev depends on libc6 (=
2.3.2.ds1-; however:
  Version of libc6 on system is 2.3.2.ds1-19.
dpkg: error processing libc6-dev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
I tried a couple of other things with the following
# apt-get install libc6    
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct
The following packages have unmet dependencies:
  libc6: Conflicts: base-files (<
3.1.2- but is to be
  libc6-dev: Depends: libc6 (=
2.3.2.ds1- but
2.3.2.ds1- is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with
no packages (or specify a solution).

# apt-get install -f   
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  base-files libc6 libc6-dev
Suggested packages:
The following packages will be upgraded:
  base-files libc6 libc6-dev
3 upgraded, 0 newly installed, 0 to remove and 89 not
1 not fully installed or removed.
Need to get 0B/8845kB of archives.
After unpacking 8192B disk space will be freed.
Do you want to continue? [Y/n] 
E: This installation run will require temporarily
removing the essential package base-files due to a
Conflicts/Pre-Depends loop. This is often bad, but if
you really want to do it, activate the
APT::Force-LoopBreak option.
E: Internal Error, Could not early remove base-files

At the moment, due to an update problem from a couple
of days previous, I can not login to this system under
X.  I get to the graphical login page with the debian
logo, but after typing my name and password the screen
goes blank and then after a few seconds the login page
returns.  I use fvwm 2.5.12.  This problem may have
been cleaned up (a lot of X related stuff has been
updated) but the libc6 dependancy problem is
preventing me from installing the updated packages.


Do you Yahoo!? 
Yahoo! Mail - Helps protect you from nasty viruses. 

Reply to: