[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#238483: Support for amd64=x86_64-linux is missing in dpkg-architecture

Package: dpkg
Version: 1.10.20
Severity: important
Tags: patch

I am trying to build some packages for the amd64 architecture. 
Without the following patch to dpkg-architecture 
I get a lot of warnings and error messages in 
the build process for many packages.

--- dpkg-architecture.pl.orig   2004-03-08 19:29:13.000000000 +0100
+++ dpkg-architecture.pl        2004-03-17 09:50:16.000000000 +0100
@@ -48,6 +48,7 @@
 require 'controllib.pl';
 %archtable=('i386',             'i386-linux',
+            'amd64',            'x86_64-linux',
             'sparc',            'sparc-linux',
	     'sparc64',          'sparc64-linux',
             'alpha',            'alpha-linux',

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.4-1-k7

Versions of packages dpkg depends on:
ii  dselect                     1.10.20      a user tool to manage Debian packa
ii  libc6                       2.3.2.ds1-11 GNU C Library: Shared libraries an

-- no debconf information

Reply to: