[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#190611: marked as done (dpkg: conflicts for dpkg-dev isn't the correct version)

Your message dated Mon, 08 Mar 2004 14:47:04 -0500
with message-id <E1B0QiO-0002kS-00@newraff.debian.org>
and subject line Bug#190611: fixed in dpkg 1.10.19
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 24 Apr 2003 18:24:19 +0000
>From mbc@debian.org Thu Apr 24 13:24:19 2003
Return-path: <mbc@debian.org>
Received: from mail.lindows.com [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 198lOM-0001me-00; Thu, 24 Apr 2003 13:24:19 -0500
Received: (qmail 14224 invoked by uid 507); 24 Apr 2003 18:33:23 -0000
Received: from unknown (HELO bakunin.sd.lindows.com) (
  by 0 with SMTP; 24 Apr 2003 18:33:23 -0000
Received: from mbc by bakunin.sd.lindows.com with local (Exim 3.33 #1 (Debian))
	id 198lN1-0000tT-00; Thu, 24 Apr 2003 11:22:55 -0700
From: Michael Cardenas <mbc@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: dpkg: conflicts for dpkg-dev isn't the correct version
X-Mailer: reportbug 1.50
Date: Thu, 24 Apr 2003 11:22:55 -0700
Message-Id: <E198lN1-0000tT-00@bakunin.sd.lindows.com>
Sender: <mbc@rilke>
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0
X-Spam-Checker-Version: SpamAssassin 2.53 (

Package: dpkg
Version: 1.9.21
Severity: normal

On another machine, not this one, I installed the latest version of dpkg from sarge. 

After doing so, I could no longer build packages because dpkg-genchanges complained that
md5sum was giving bogus output. I had dpkg-dev 1.9.21 on my machine. Dpkg 1.10 conflicts with
dpkg-dev << 1.9, so it didn't complain. Shouldn't it conflict with dpkg-dev << 1.10 ? 

After installing the new dpkg-dev from sarge, I was again able to build packages.
-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux bakunin 2.4.20 #1 Sun Feb 16 14:27:31 PST 2003 i686

Versions of packages dpkg depends on:
ii  libc6                   2.2.5-6.lindows3 GNU C Library: Shared libraries an
ii  libncurses5             5.2.20020112a-7  Shared libraries for terminal hand
ii  libstdc++2.10-glibc2.2  1:2.95.4-7       The GNU stdc++ library

Received: (at 190611-close) by bugs.debian.org; 8 Mar 2004 19:53:46 +0000
>From katie@ftp-master.debian.org Mon Mar 08 11:53:46 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B0Qos-0003FI-00; Mon, 08 Mar 2004 11:53:46 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1B0QiO-0002kS-00; Mon, 08 Mar 2004 14:47:04 -0500
From: Scott James Remnant <scott@netsplit.com>
To: 190611-close@bugs.debian.org
X-Katie: $Revision: 1.44 $
Subject: Bug#190611: fixed in dpkg 1.10.19
Message-Id: <E1B0QiO-0002kS-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Mon, 08 Mar 2004 14:47:04 -0500
Delivered-To: 190611-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_08 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=HAS_BUG_NUMBER autolearn=no 

Source: dpkg
Source-Version: 1.10.19

We believe that the bug you reported is fixed in the latest version of
dpkg, which is due to be installed in the Debian FTP archive:

  to pool/main/d/dpkg/dpkg-dev_1.10.19_all.deb
  to pool/main/d/dpkg/dpkg-doc_1.10.19_all.deb
  to pool/main/d/dpkg/dpkg_1.10.19.dsc
  to pool/main/d/dpkg/dpkg_1.10.19.tar.gz
  to pool/main/d/dpkg/dpkg_1.10.19_i386.deb
  to pool/main/d/dpkg/dselect_1.10.19_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 190611@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Scott James Remnant <scott@netsplit.com> (supplier of updated dpkg package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Mon,  8 Mar 2004 19:05:32 +0000
Source: dpkg
Binary: dpkg-doc dpkg dselect dpkg-dev dpkg-static
Architecture: source all i386
Version: 1.10.19
Distribution: unstable
Urgency: high
Maintainer: Dpkg Development <debian-dpkg@lists.debian.org>
Changed-By: Scott James Remnant <scott@netsplit.com>
 dpkg       - Package maintenance system for Debian
 dpkg-dev   - Package building tools for Debian
 dpkg-doc   - Dpkg Internals Documentation
 dselect    - a user tool to manage Debian packages
Closes: 139781 157437 168443 170953 190611 199489 199693 211566 213038 213543 213846 217286 217943 221989 222760 225692 228253 228379 232025 232916 235266
 dpkg (1.10.19) unstable; urgency=high
   * Distinguish unmet build dependencies from build conflicts.
     Closes: #217943, #235266.
   * Force NULL-termination of all tar file entry names.  Closes: #232025.
   * Allow dselect to use the full window width.  Closes: #139781.
   * Pass correct number of arguments for format string when out of disk
     space.  Closes: #213038, #217286, #213543, #213846.
   * Remove duplicated entries from ChangeLog.  Closes: #157437.
   * Fix dpkg-buildpackage when used with PGP.  Closes: #232916.
   * Update support for Debian FreeBSD.  Closes: #211566.
   * Store Architecture in the status file.  Closes: #228253.
   * Don't print offending lines in md5sum.  Closes: #170953.
   * Check bounds of md5sum lines.  Closes: #168443, #199489, #199693.
 dpkg ( unstable; urgency=medium
   * Non-maintainer upload to fix release-critical bugs.
   * Terminate string buffer in main/remove.c.  Closes: #228379.
   * Prevent stashing of hardlinked devices and setuid or setgid binaries
     by removing permissions on upgrade as well as on remove.
     Closes: #225692.
   * Update dpkg conflicts to << 1.10, instead of 1.9.
     Closes: #190611, #221989, #222760.
 5a4c39cb6903694ec7ff0ebcd5afc33d 798 base required dpkg_1.10.19.dsc
 a735a1f14cc985ad083b46bce425001b 1547265 base required dpkg_1.10.19.tar.gz
 86386707c685a60c4132def2494b3657 1086080 base required dpkg_1.10.19_i386.deb
 5bf8ab50684b58b8619f2c7d982ac47f 95024 base required dselect_1.10.19_i386.deb
 088fe395e33835351e2ccdc3f8122a31 114618 utils standard dpkg-dev_1.10.19_all.deb
 294b7c2bf86172671a91b050c6db8a1a 10636 doc optional dpkg-doc_1.10.19_all.deb

Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: