[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#151971: dpkg: uninstallable -- overlap -- deja vu

Package: dpkg
Version: 1.9.21
Severity: grave

I could have sworn I already filed this bug, but 'bugview dpkg' doesn't
show it, so here we go (again?)

Preparing to replace dpkg 1.9.21 (using .../archives/dpkg_1.10_i386.deb) ...
Unpacking replacement dpkg ...
dpkg: error processing /var/cache/apt/archives/dpkg_1.10_i386.deb (--unpack):
 trying to overwrite `/usr/bin/dpkg-query', which is also in package dpkg-iasearch
dpkg-deb: subprocess paste killed by signal (Broken pipe)
E: Sub-process /usr/bin/dpkg exited unexpectedly

For a package as central as dpkg, you'd think the maintainers would make
a simple check to determine if new-to-the-package binaries conflicted
with the existing Debian namespace.  Shameful.

(Is there a fault in the BTS, as I'm rather certain I've already filed
about this?   I doubt I'd dream about such a strange thing.)

-- System Information
Debian Release: 3.0
Kernel Version: Linux phoenix 2.4.18 #1 Sun Mar 3 20:15:51 UTC 2002 i586 unknown

Versions of the packages dpkg depends on:
ii  libc6          2.2.5-7        GNU C Library: Shared libraries and Timezone
ii  libncurses5    5.2.20020112a- Shared libraries for terminal handling
ii  libstdc++2.10- 2.95.4-9       The GNU stdc++ library

To UNSUBSCRIBE, email to debian-dpkg-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: