[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#151727: dpkg: dselect message " Do you wish to change (overwrite) it?[y/N]" hazardous



Package: dpkg
Version: 1.9.20
Severity: important

in dselct, choosing the apt-get method, we are faced with
   Do you wish to change (overwrite) it?[y/N] 
regarding our sources.list file.

Well, already twice in the last month I have been shocked that my
sources.list was blown away by saying "y".  I thought it meant
"change, or even overwrite", "change, and optionally overwrite"...
well, indeed, it means "change (i.e. overwrite)" ... what a surprise.

Therefore will you kindly speak clearer:
   Do you wish to ERASE it?[y/N]

By the way, you could also add e for calling $EDITOR, etc.

Anyway, many users will find their hard tuned sources.list blown away
"because they didn't understand English".

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux debian 2.4.18-k7 #1 Sun Apr 14 13:19:11 EST 2002 i686
Locale: LANG=zh_TW.Big5, LC_CTYPE=zh_TW.Big5

Versions of packages dpkg depends on:
ii  libc6                    2.2.5-6         GNU C Library: Shared libraries an
ii  libncurses5              5.2.20020112a-7 Shared libraries for terminal hand
ii  libstdc++2.10-glibc2.2   1:2.95.4-7      The GNU stdc++ library



-- 
To UNSUBSCRIBE, email to debian-dpkg-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



Reply to: