[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unnecessarily tight dependency on R for r-cran-scales

On Sat, 10 Aug 2013, Charles Plessy wrote:

Le Fri, Aug 09, 2013 at 03:21:36PM +0530, Faheem Mitha a écrit :

When I try to install r-cran-scales in unstable, I get

root@orwell:/home/faheem# apt-get install r-cran-scales


The following packages have unmet dependencies:
 r-cran-scales : Depends: r-base-core (>= 3.0.1-3) but 3.0.1-3~wheezycran3.0 is to be installed
E: Unable to correct problems, you have held broken packages.

I'm using Dirk's CRAN wheezy backport of R 3.0 from unstable.

Hi Faheem,

r-cran-scales was built in Sid, where 3.0.1-3 was the latest version at that time, and therefore r-cran-scales demands it. The backport in Wheezy has a lower version number, and therefore does not satisfy the demand.

One could consider adding systematically the magic tilde to the version numbers passed to ${R:Depends}, but at that point, I think that it is even better to implement a versionned R API number.

A versioned R API number would be a good idea. Is this supported by R? What would be involved in implementing it?

                                                       Regards, Faheem

Reply to: