Re: dpkg predependency against tar >= 1.23, objections?
On Thu, 2011-09-29 at 18:50:35 +0200, Raphael Hertzog wrote:
> On Sun, 25 Sep 2011, Guillem Jover wrote:
> > > $ sudo apt-get install dpkg-dev
> > > tar: unrecognized option `--warning=no-timestamp'
> > > Try `tar --help' or `tar --usage' for more information.
> > > dpkg-deb: error: subprocess tar returned error exit status 64
> > > dpkg: error processing /var/cache/apt/archives/dpkg-dev_1.16.1_all.deb (--unpack):
> > > subprocess dpkg-deb --control returned error exit status 2
> > > I manually unpacked the latest tar package (version 1.26-2) with ar
> > > and tar, and overwrote /bin/tar . dpkg worked again.
> > The tar version introducing those options was 1.23, present in
> > squeeze. So it seems you are trying to upgrade a system with packages
> > still from lenny to a mix of squeeze and sid?
> > This is generally not supported, but I also agree this outcome is not
> > desirable either, I'll probably add a versioned Pre-Depends on the
> > required tar, after running it through debian-devel.
> So cc-ing debian-devel with this mail. Does anyone have an objection
> against dpkg adding this "tar (>= 1.23)" pre-dependency?
> For reference it's the fix for #640298 that added the --warning=no-timestamp
Ok, given there does not seem to be arguments against, I'll queue this
for my next push. If someone sees a problem with this it can still be
reverted or something before uploading 1.16.2.