[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#608609: ITP: libpackage-pkg-perl -- collection of package manipulation utilities

Package: wnpp
Owner: Jonathan Yu <jawnsy@cpan.org>
Severity: wishlist
X-Debbugs-CC: debian-devel@lists.debian.org,debian-perl@lists.debian.org

* Package name    : libpackage-pkg-perl
  Version         : 0.0019
  Upstream Author : Robert Krimen <robertkrimen@gmail.com>
* URL             : http://search.cpan.org/dist/Package-Pkg/
* License         : Artistic or GPL-1+
  Programming Lang: Perl
  Description     : collection of package manipulation utilities

Package::Pkg is Perl module that provides several utility functions useful
for manipulating packages and their subroutines. You can install arbitrary
code references as functions in a given namespace, alias functions from one
package to another, and set up an exporter.

In many respects, this package provides functionality similar to Sub::Install
(see libsub-install-perl) and Sub::Exporter (see libsub-exporter-perl).

NOTE: this package is required for Getopt::Usaginator
(libgetopt-usaginator-perl), which in turn is required for an upgraded
Config::JFDI (libconfig-jfdi-perl).

Reply to: