[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: logitech mouse [was: Lost Trust]

"Francesco P. Lovergine" <frankie@debian.org> wrote:
> On Thu, Jun 03, 2004 at 12:24:51PM +0200, Francesco P. Lovergine wrote:
> > On Mon, May 31, 2004 at 04:43:06PM -0700, Eric Wong wrote:
> > > Erik Steffl <steffl@bigfoot.com> wrote:
> > > >   if the driver is available somewhere it is probably fairly easy to 
> > > > make it work with debian kernel. sometime it's not that easy to get the 
> > > > HW working, e.g. when I got the SATA HD I had to spend time on lkml, 
> > > > apply patches (well, use ac kernel with manually applied libata5 
> > > > patches) etc. lot of fun. and now e.g. extra button on logitech mouse 
> > > > doesn't work (worked fine with 2.4.x but 2.6.x is too smart (more like 
> > > > smart-ass)).
> > > 
> > > Which Logitech mouse?  I'm assuming it's PS/2 since USB mice work more
> > > or less the same (evdev is recommended for USB).  I co-wrote the 2.6
> > > Logitech PS/2++ driver and also maintain a Debian package[1] for the
> > > logitech_applet which controls USB functions.
> > > 
> > > 
> > > 1 - http://des.petta-tech.com/~eric/debian (a sponsor would be helpful)
> > > 
> > 
> > You have found one :)

Still interested?  Let me know if there's anything I can improve in my
package, too.  Thanks.

> > Anyway, I have the same problems with Logitech MouseMan Traveler
> > which is a USB mouse: the middle button is working but is not
> > detected as a wheel. I did not try the evdev protocol indeed.
> > I'll check that and the mouse ID ASAP.

mouse IDs are irrelevant to USB mice as far as the kernel is concerned
(but not the logitech_applet I've packaged).

> Uhm, with evdev same result. Also worse if possible: the middle button
> now does not work as it should in selecting parts of texts, the effect
> is the same of a double-click with middle button, i.e. no selections at
> all.

Double clicking?  If it were just acting like another button (single
click), it would be because of xmodmap (or forgetting to run it).
Does enabling evbug or using xev give any useful info?

> At the same time I see that evdev does not work as it should with
> synaptics (without xfree86-driver-synaptics): the device works
> but the pointer is sadly frozen. Add to this that for misterious
> reason I see the PC speaker within /proc/bus/input/devices
> (and obsviously it does not work at all) and the picture is complete!

Sorry, I don't know much about the synaptics device.  There's a PC
speaker driver in 2.6 (in the input section, oddly), but having no PC
speaker, I've never played with that, either.

> BTW, probably this is not the right ML for this kind of issues....

Probably not, but it started here and I happened to be reading.  (I
don't read MLs too often).

Eric Wong                normalperson@yhbt.net
Petta Technology, Inc      eric@petta-tech.com

Reply to: