[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

versioned Build-Depends?

I tried the following in a library I am currently packaging:

  Source: libhid
  Build-Depends: debhelper (>= 4.0.0), libusb-dev (>= 0.1.8)

  Package: libhid-dev

Now, when I call dpkg-buildpackage, it happily starts building the
package, even though

ii  libusb-dev     0.1.7-6        Userspace USB programming library

Does this mean that versioned Build-Depends don't really work? Or am
I doing something wrong?

ii  debhelper      4.1.90         helper programs for debian/rules
ii  dpkg-dev       1.10.18        Package building tools for Debian

Please do not CC me when replying to lists; I read them!
 .''`.     martin f. krafft <madduck@debian.org>
: :'  :    proud Debian developer, admin, and user
`. `'`
  `-  Debian - when you have better things to do than fixing a system
Invalid/expired PGP subkeys? Use subkeys.pgp.net as keyserver!

Attachment: signature.asc
Description: Digital signature

Reply to: