[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

GDM package is outdated (still from gnome 2.2) and contains lots ofbugs :(

From: Mantas Kriaučiūnas <mantas@akl.lt>
on debian-gtk-gnome ml 10/2/2004.


Are there any plans to release gdm for gnome 2.4 ?
Now debian has outdated version for Gnome 2.2 - look at
http://www.jirka.org/gdm.html - "2.4.1.x are the GNOME2.2 stable
versions,[..] 2.4.4.x are the GNOME 2.4 stable versions. [...]"

Several new stable versions of gdm released by upstream - for example,,,,,, and
with lots of important changes (look for example at new graphical face
bowser at

- Completely new session setup, born out of discussions with Oswald
  Buddenhagen, the KDM maintainer, which will bring about common session
  setup for both GDM and KDM.  We now basically have a common
  /etc/X11/dm/Sessions directory where there are .desktop files are stored
  which describe sessions and these will be shared among KDM and GDM.
  Among other things this also makes the face browser default to using
  ~/.face and the per user saved info is in ~/.dmrc

(I think this is very importand for Debian)

- The greeter.dtd is updated and there is theme creation documentation
  (Brian Cameron, Aidan Butler, me)

- A face browser for the graphical greeter.  This is selecting by selecting
  a theme that implements it.  Add happygnome-list which does.
  (Patrizio Bruno, me)

- The standard greeter has a GtkTreeView based face browser based on the
  new one from the graphical greeter.

- Accesibility work.  Add posibility of adding modules to the greeter
through  AddGtkModules and GtkModulesList.  Add guesture listeners.  Dwell
mouse  events.  (Niall Power, Brian Cameron)

- Attempt at getting things HIG-ified

- Add a "Delete theme" button to gdmsetup, add a scroll window to the
  theme preview, fixes #110302 and #104757

- PAM now asks for username itself.  This made LocalNoPasswordUsers
impossible,  and so that was removed.  This way hopefully we should work
with some more  pam setups, such as smartcard ones.  Fixes issues from

GDM for Gnome 2.4 already has up to date translations (look at

People reported bugs about this, but there are no real work from maintainer
:( See this bugreport:

For more info about new gdm look at this bugreport:

Btw, gdm contains lots of unfixed bugs (about 70), look at
bugs.debian.org/gdm :(

It seems, that debian gdm maintainer doesn't have enought time to fix bugs
and to maintain this package properly, for example default language bug is
about 2 years old. People submitted patches to fix this bug, but patches
are not included in debian package :( (look at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=192143 and
for more info.)
This bug exists from these times, when I started to use Gnome from debian
unstable!!! (earlier I used Gnome from Stormix and from HelixCode)
Same with poweroff (restart) bug - some people already have written patch
(and have sent to debian-gtk-gnome mailing list) for this, why this patch
isn't in Debians gdm package?

It seems, it becomes a bad tradition that Gnome in Debian has problems
because of outdated gdm package :( Look at bugreports like these old:

I see only one solution - debian-gnome packaging team should help to
maintain such important package like gdm.

Please, package new version, debian users need localised and user-friendly
way to login ant logout :)

Good luck,
Mantas Kriaučiūnas
Email & Jabber ID: mantas@akl.lt	ICQ: mantiena <44451746>
Public Organization "Open Source for Lithuania"	www.akl.lt

Reply to: