[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libgd2{{,-noxpm,-xpm},-dev}



It seems that libgd2 in unstable generates libgd2-xpm, libgd2-noxpm, and
associated -dev packages, but the old libgd2 and libgd2-dev packages
were seemingly silently removed. This breaks some packages:

package: modlogan
depends: libadns1, libc6 (>= 2.2.4-4), libgd2 (>= 2.0.1-11) | libgd2-noxpm (>= 2.0.1-11), libpcre3, libpng2 (>= 1.0.12), libxml2 (>= 2.4.19-4), zlib1g (>= 1:1.1.4), debconf
# minor, should be libgd2-xpm | libgd2-noxpm; causes apt to not
# select and upgrade to newer libgd2-xpm package

package: analog
Depends: libc6 (>= 2.2.5-13), libgd2-noxpm (>= 2.0.1) | libgd2 (>= 2.0.1), libjpeg62, libpcre3, libpng3, zlib1g (>= 1:1.1.4), debconf (>= 0.5), perl
# again minor; fixed in Incoming

package: libg20
depends: libc6 (>= 2.2.4-4), libgd2 (>= 2.0.1) | libgd2-noxpm (>= 2.0.1), xlibs (>> 4.1.0)
# again minor

package: libgd-ruby
depends: libc6 (>= 2.2.3-7), libfreetype6, libgd2 (>= 2.0.1-1), libjpeg62, libpng2 (>= 1.0.12), libruby (>= 1.6.4-11), libttf2, xlibs (>> 4.1.0), zlib1g (>= 1:1.1.3)
# uninstallable

package: grass
depends: fftw2 | fftw2-double, libc6 (>= 2.2.4-4), libfreetype6, libgd2 (>= 2.0.1) | libgd2-noxpm (>= 2.0.1), libncurses5 (>= 5.2.20020112a-1), libpng3,libtiff3g, tcl8.3 (>= 8.3.0), tk8.3 (>= 8.3.0), xlibmesa3 | libgl1, xlibs (>> 4.1.0), zlib1g (>= 1:1.1.4), csh | c-shell
# again, minor

Someone want to file bugs on and/or fix these? And isn't
debian-devel-announce where a library package maintainer should post
before breaking dependent packages in this way?

-- 
see shy jo

Attachment: pgp_zq6mUFbRp.pgp
Description: PGP signature


Reply to: